Commit 0a768337 authored by maeda's avatar maeda

Drop Ruby 2.2 support (#30356).


git-svn-id: https://svn.redmine.org/redmine/trunk@17887 e93f8b46-1217-0410-a6f0-8f06a7374b81
parent e9972494
......@@ -10,8 +10,8 @@ gem "actionpack-xml_parser"
gem "roadie-rails", "~> 1.3.0"
gem "mimemagic"
gem "mail", "~> 2.7.1"
gem "csv", "~> 3.0.1" if RUBY_VERSION >= "2.3" && RUBY_VERSION < "2.6"
gem "nokogiri", (RUBY_VERSION >= "2.3" ? "~> 1.10.0" : "~> 1.9.1")
gem "csv", "~> 3.0.1" if RUBY_VERSION < "2.6"
gem "nokogiri", "~> 1.10.0"
gem "i18n", "~> 0.7.0"
gem "rbpdf", "~> 1.19.6"
......
......@@ -50,8 +50,7 @@ class ImportsController < ApplicationController
redirect_to import_mapping_path(@import)
end
# TODO: Remove ArgumentError when support for Ruby 2.2 is dropped (#28689)
rescue CSV::MalformedCSVError, ArgumentError, EncodingError => e
rescue CSV::MalformedCSVError, EncodingError => e
if e.is_a?(CSV::MalformedCSVError) && e.message !~ /Invalid byte sequence/
flash.now[:error] = l(:error_invalid_csv_file_or_settings)
else
......
......@@ -7,7 +7,7 @@ http://www.redmine.org/
== Requirements
* Ruby >= 2.2.2
* Ruby >= 2.3
* RubyGems
* Bundler >= 1.5.0
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment