Commit 824fc0a6 authored by marutosijp's avatar marutosijp

travis: fix MariaDB 5.5 test error

<pre>
The following packages have unmet dependencies:
mariadb-server : Depends: mariadb-server-5.5 (= 5.5.42+maria-1~precise) but it is not going to be installed
</pre>

git-svn-id: https://svn.redmine.org/redmine/trunk@14231 e93f8b46-1217-0410-a6f0-8f06a7374b81
parent 1e3bd66e
......@@ -61,6 +61,7 @@ before_install:
sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xcbcb082a1bb943db ;
MARIADB_VER=`echo $DB | sed -e 's/mariadb-//'` ;
sudo add-apt-repository ''"deb http://ftp.osuosl.org/pub/mariadb/repo/${MARIADB_VER}/ubuntu precise main"'' ;
sudo cp test/travis/mariadb.pref /etc/apt/preferences.d/mariadb.pref ;
sudo apt-get update ;
sudo DEBIAN_FRONTEND=noninteractive apt-get -q --yes --force-yes -f --option DPkg::Options::=--force-confnew install mariadb-server ;
sudo apt-get install libmariadbd-dev ;
......
# https://mariadb.com/kb/en/mariadb/installing-mariadb-deb-files/
# /etc/apt/preferences.d/
Package: *
Pin: origin ftp.osuosl.org
Pin-Priority: 1000
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment