Commit 1d47fa11 authored by jplang's avatar jplang
Browse files

INSTALL update (#12913).

git-svn-id: https://svn.redmine.org/redmine/trunk@11592 e93f8b46-1217-0410-a6f0-8f06a7374b81
parent 667a7ed9
......@@ -7,7 +7,7 @@ http://www.redmine.org/
== Requirements
* Ruby 1.8.7, 1.9.2 or 1.9.3
* Ruby 1.8.7, 1.9.2, 1.9.3 or 2.0.0
* RubyGems
* Bundler >= 1.0.21
......@@ -15,6 +15,7 @@ http://www.redmine.org/
* MySQL (tested with MySQL 5.1)
* PostgreSQL (tested with PostgreSQL 9.1)
* SQLite3 (tested with SQLite 3.6)
* SQLServer (tested with SQLServer 2012)
Optional:
* SCM binaries (e.g. svn, git...), for repository browsing (must be available in PATH)
......@@ -39,6 +40,12 @@ Optional:
of the rmagick gem using:
bundle install --without development test rmagick
Only the gems that are needed by the adapters you've specified in your database
configuration file are actually installed (eg. if your config/database.yml
uses the 'mysql2' adapter, then only the mysql2 gem will be installed). Don't
forget to re-run `bundle install` when you change config/database.yml for using
other database adapters.
If you need to load some gems that are not required by Redmine core (eg. fcgi),
you can create a file named Gemfile.local at the root of your redmine directory.
It will be loaded automatically when running `bundle install`.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment