GitLab steht Mittwoch, den 23. September, zwischen 10:00 und 12:00 Uhr aufgrund von Wartungsarbeiten nicht zur Verfügung.

Gemfile 1.99 KB
Newer Older
jplang's avatar
jplang committed
1
source 'http://rubygems.org'
2

jplang's avatar
jplang committed
3
gem 'rails', '3.2.8'
4
gem "jquery-rails", "~> 2.0.2"
tmaruyama's avatar
tmaruyama committed
5
gem "i18n", "~> 0.6.0"
emassip's avatar
emassip committed
6
gem "coderay", "~> 1.0.6"
7
gem "fastercsv", "~> 1.5.0", :platforms => [:mri_18, :mingw_18, :jruby]
jplang's avatar
jplang committed
8
gem "builder"
9 10 11

# Optional gem for LDAP authentication
group :ldap do
jplang's avatar
jplang committed
12
  gem "net-ldap", "~> 0.3.1"
13 14 15 16 17
end

# Optional gem for OpenID authentication
group :openid do
  gem "ruby-openid", "~> 2.1.4", :require => "openid"
jplang's avatar
jplang committed
18
  gem "rack-openid"
19 20
end

21 22 23 24 25 26 27 28
# Optional gem for exporting the gantt to a PNG file, not supported with jruby
platforms :mri, :mingw do
  group :rmagick do
    # RMagick 2 supports ruby 1.9
    # RMagick 1 would be fine for ruby 1.8 but Bundler does not support
    # different requirements for the same gem on different platforms
    gem "rmagick", ">= 2.0.0"
  end
29 30 31 32 33
end

# Database gems
platforms :mri, :mingw do
  group :postgresql do
jplang's avatar
jplang committed
34
    gem "pg", ">= 0.11.0"
35 36 37 38 39 40 41 42 43 44 45 46 47 48 49
  end

  group :sqlite do
    gem "sqlite3"
  end
end

platforms :mri_18, :mingw_18 do
  group :mysql do
    gem "mysql"
  end
end

platforms :mri_19, :mingw_19 do
  group :mysql do
jplang's avatar
jplang committed
50
    gem "mysql2", "~> 0.3.11"
51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71
  end
end

platforms :jruby do
  gem "jruby-openssl"

  group :mysql do
    gem "activerecord-jdbcmysql-adapter"
  end

  group :postgresql do
    gem "activerecord-jdbcpostgresql-adapter"
  end

  group :sqlite do
    gem "activerecord-jdbcsqlite3-adapter"
  end
end

group :development do
  gem "rdoc", ">= 2.4.2"
emassip's avatar
emassip committed
72
  gem "yard"
73 74 75
end

group :test do
tmaruyama's avatar
tmaruyama committed
76
  gem "shoulda", "~> 2.11"
77 78
  # Shoulda does not work nice on Ruby 1.9.3 and seems to need test-unit explicitely.
  gem "test-unit", :platforms => [:mri_19]
tmaruyama's avatar
tmaruyama committed
79
  gem "mocha", "0.12.3"
80 81
end

82 83
local_gemfile = File.join(File.dirname(__FILE__), "Gemfile.local")
if File.exists?(local_gemfile)
jplang's avatar
jplang committed
84
  puts "Loading Gemfile.local ..." if $DEBUG # `ruby -d` or `bundle -v`
85
  instance_eval File.read(local_gemfile)
jplang's avatar
jplang committed
86 87
end

88
# Load plugins' Gemfiles
89
Dir.glob File.expand_path("../plugins/*/Gemfile", __FILE__) do |file|
90 91 92
  puts "Loading #{file} ..." if $DEBUG # `ruby -d` or `bundle -v`
  instance_eval File.read(file)
end