Gemfile 3.86 KB
Newer Older
jplang's avatar
jplang committed
1
source 'https://rubygems.org'
2

jplang's avatar
jplang committed
3
if Gem::Version.new(Bundler::VERSION) < Gem::Version.new('1.5.0')
4
  abort "Redmine requires Bundler 1.5.0 or higher (you're using #{Bundler::VERSION}).\nPlease update with 'gem update bundler'."
jplang's avatar
jplang committed
5 6
end

marutosijp's avatar
marutosijp committed
7
gem "rails", "4.2.8"
8
gem "addressable", "2.4.0" if RUBY_VERSION < "2.0"
9
gem "jquery-rails", "~> 3.1.4"
jplang's avatar
jplang committed
10
gem "coderay", "~> 1.1.1"
11
gem "request_store", "1.0.5"
12
gem "mime-types", (RUBY_VERSION >= "2.0" ? "~> 3.0" : "~> 2.99")
jplang's avatar
jplang committed
13
gem "protected_attributes"
14
gem "actionpack-xml_parser"
15
gem "roadie-rails"
16
gem "mimemagic"
jplang's avatar
jplang committed
17

18
gem "nokogiri", (RUBY_VERSION >= "2.1" ? ">= 1.7.0" : "~> 1.6.8")
marutosijp's avatar
marutosijp committed
19
gem "i18n", "~> 0.7.0"
20
gem "ffi", "1.9.14", :platforms => :mingw if RUBY_VERSION < "2.0"
21

22
# Request at least rails-html-sanitizer 1.0.3 because of security advisories
23 24
gem "rails-html-sanitizer", ">= 1.0.3"

jplang's avatar
jplang committed
25
# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
26
gem 'tzinfo-data', platforms: [:mingw, :x64_mingw, :mswin, :jruby]
jplang's avatar
jplang committed
27
gem "rbpdf", "1.19.0"
28 29 30

# Optional gem for LDAP authentication
group :ldap do
marutosijp's avatar
marutosijp committed
31
  gem "net-ldap", "~> 0.12.0"
32 33 34 35
end

# Optional gem for OpenID authentication
group :openid do
36
  gem "ruby-openid", "~> 2.3.0", :require => "openid"
jplang's avatar
jplang committed
37
  gem "rack-openid"
38 39
end

40
platforms :mri, :mingw, :x64_mingw do
jplang's avatar
jplang committed
41
  # Optional gem for exporting the gantt to a PNG file, not supported with jruby
42
  group :rmagick do
marutosijp's avatar
marutosijp committed
43
    gem "rmagick", ">= 2.14.0"
44
  end
jplang's avatar
jplang committed
45 46 47

  # Optional Markdown support, not for JRuby
  group :markdown do
jplang's avatar
jplang committed
48
    gem "redcarpet", "~> 3.3.2"
jplang's avatar
jplang committed
49
  end
50 51 52
end

platforms :jruby do
53 54
  # jruby-openssl is bundled with JRuby 1.7.0
  gem "jruby-openssl" if Object.const_defined?(:JRUBY_VERSION) && JRUBY_VERSION < '1.7.0'
55
  gem "activerecord-jdbc-adapter", "~> 1.3.2"
56
end
57

58 59
# Include database gems for the adapters found in the database
# configuration file
60
require 'erb'
61
require 'yaml'
62 63
database_file = File.join(File.dirname(__FILE__), "config/database.yml")
if File.exist?(database_file)
64
  database_config = YAML::load(ERB.new(IO.read(database_file)).result)
65 66 67 68
  adapters = database_config.values.map {|c| c['adapter']}.compact.uniq
  if adapters.any?
    adapters.each do |adapter|
      case adapter
69
      when 'mysql2'
70
        gem "mysql2", "~> 0.3.11", :platforms => [:mri, :mingw, :x64_mingw]
71 72
        gem "activerecord-jdbcmysql-adapter", :platforms => :jruby
      when 'mysql'
73 74
        gem "activerecord-jdbcmysql-adapter", :platforms => :jruby
      when /postgresql/
marutosijp's avatar
marutosijp committed
75
        gem "pg", "~> 0.18.1", :platforms => [:mri, :mingw, :x64_mingw]
76 77
        gem "activerecord-jdbcpostgresql-adapter", :platforms => :jruby
      when /sqlite3/
78 79
        gem "sqlite3", (RUBY_VERSION < "2.0" && RUBY_PLATFORM =~ /mingw/ ? "1.3.12" : "~>1.3.12"),
                       :platforms => [:mri, :mingw, :x64_mingw]
80
        gem "jdbc-sqlite3", ">= 3.8.10.1", :platforms => :jruby
81
        gem "activerecord-jdbcsqlite3-adapter", :platforms => :jruby
82
      when /sqlserver/
83
        gem "tiny_tds", (RUBY_VERSION >= "2.0" ? "~> 1.0.5" : "~> 0.7.0"), :platforms => [:mri, :mingw, :x64_mingw]
84
        gem "activerecord-sqlserver-adapter", :platforms => [:mri, :mingw, :x64_mingw]
85
      else
jplang's avatar
jplang committed
86
        warn("Unknown database adapter `#{adapter}` found in config/database.yml, use Gemfile.local to load your own database gems")
87 88 89
      end
    end
  else
90
    warn("No adapter found in config/database.yml, please configure it first")
91
  end
92
else
93
  warn("Please configure your config/database.yml first")
94 95 96
end

group :development do
marutosijp's avatar
marutosijp committed
97
  gem "rdoc", "~> 4.3"
emassip's avatar
emassip committed
98
  gem "yard"
99 100 101
end

group :test do
jplang's avatar
jplang committed
102
  gem "minitest"
jplang's avatar
jplang committed
103
  gem "rails-dom-testing"
marutosijp's avatar
marutosijp committed
104
  gem "mocha"
105
  gem "simplecov", "~> 0.9.1", :require => false
jplang's avatar
jplang committed
106
  # For running UI tests
107
  gem "capybara"
jplang's avatar
jplang committed
108
  gem "selenium-webdriver", "~> 2.53.4"
109 110
end

111 112
local_gemfile = File.join(File.dirname(__FILE__), "Gemfile.local")
if File.exists?(local_gemfile)
jplang's avatar
jplang committed
113
  eval_gemfile local_gemfile
jplang's avatar
jplang committed
114 115
end

116
# Load plugins' Gemfiles
117
Dir.glob File.expand_path("../plugins/*/{Gemfile,PluginGemfile}", __FILE__) do |file|
jplang's avatar
jplang committed
118
  eval_gemfile file
119
end