Commit e935d2ec authored by Stan Hu's avatar Stan Hu

Bump premailer-rails gem to 1.9.7 and its dependencies to prevent network retrieval of assets

Since asset compilation was disabled in GitLab 9.3, the premailer-rails gem
would fall back to fetching assets via HTTP(s) since the Sidekiq working
directory was not the Rails root. In some instances, SSL verification would
fail, preventing e-mails from being sent.

premailer-rails 1.9.7 has a fix
(https://github.com/fphilipe/premailer-rails/pull/195) that uses an absolute
directory to load assets from the filesystem so that the assets can be fetched
locally instead of over the network.

Closes #34231
parent 47face01
......@@ -256,7 +256,7 @@ gem 'base32', '~> 0.3.0'
# Sentry integration
gem 'sentry-raven', '~> 2.4.0'
gem 'premailer-rails', '~> 1.9.0'
gem 'premailer-rails', '~> 1.9.7'
# I18n
gem 'ruby_parser', '~> 3.8', require: false
......
......@@ -137,7 +137,7 @@ GEM
crack (0.4.3)
safe_yaml (~> 1.0.0)
creole (0.5.0)
css_parser (1.4.1)
css_parser (1.5.0)
addressable
d3_rails (3.5.11)
railties (>= 3.1.0)
......@@ -589,10 +589,11 @@ GEM
websocket-driver (>= 0.2.0)
posix-spawn (0.3.11)
powerpack (0.1.1)
premailer (1.8.6)
css_parser (>= 1.3.6)
premailer (1.10.4)
addressable
css_parser (>= 1.4.10)
htmlentities (>= 4.0.0)
premailer-rails (1.9.2)
premailer-rails (1.9.7)
actionmailer (>= 3, < 6)
premailer (~> 1.7, >= 1.7.9)
prometheus-client-mmap (0.7.0.beta5)
......@@ -1045,7 +1046,7 @@ DEPENDENCIES
peek-sidekiq (~> 1.0.3)
pg (~> 0.18.2)
poltergeist (~> 1.9.0)
premailer-rails (~> 1.9.0)
premailer-rails (~> 1.9.7)
prometheus-client-mmap (~> 0.7.0.beta5)
pry-byebug (~> 3.4.1)
pry-rails (~> 0.3.4)
......
---
title: Bump premailer-rails gem to 1.9.7 and its dependencies to prevent network retrieval
of assets
merge_request:
author:
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment