check browser version, blacklisting outdated IE (version < 10)

parent fe104386
......@@ -13,8 +13,9 @@ v 7.7.0
-
-
-
- Add alert message in case of outdated browser (IE < 10)
-
-
v 7.6.0
......@@ -62,7 +63,7 @@ v 7.5.0
- Performance improvements
- Fix post-receive issue for projects with deleted forks
- New gitlab-shell version with custom hooks support
- Improve code
- Improve code
- GitLab CI 5.2+ support (does not support older versions)
- Fixed bug when you can not push commits starting with 000000 to protected branches
- Added a password strength indicator
......
......@@ -30,6 +30,9 @@ gem 'omniauth-github'
gem 'omniauth-shibboleth'
gem 'omniauth-kerberos'
# Browser detection
gem "browser"
# Extracting information from a git repository
# Provide access to Gitlab::Git library
gem "gitlab_git", '7.0.0.rc12'
......
......@@ -49,6 +49,7 @@ GEM
debug_inspector (>= 0.0.1)
bootstrap-sass (3.0.3.0)
sass (~> 3.2)
browser (0.7.2)
builder (3.2.2)
capybara (2.2.1)
mime-types (>= 1.16)
......@@ -604,6 +605,7 @@ DEPENDENCIES
better_errors
binding_of_caller
bootstrap-sass (~> 3.0)
browser
capybara (~> 2.2.1)
carrierwave
coffee-rails
......
......@@ -227,6 +227,18 @@ li.note {
}
}
.browser-alert {
padding: 10px;
text-align: center;
background: #C67;
color: #fff;
font-weight: bold;
a {
color: #fff;
text-decoration: underline;
}
}
.warning_message {
border-left: 4px solid #ed9;
color: #b90;
......
......@@ -293,4 +293,8 @@ module ApplicationHelper
path << "?#{options.to_param}"
path
end
def outdated_browser?
browser.ie? && browser.version.to_i < 10
end
end
......@@ -44,3 +44,5 @@
%li.hidden-xs
= link_to current_user, class: "profile-pic", id: 'profile-pic' do
= image_tag avatar_icon(current_user.email, 26), alt: 'User activity'
= render 'shared/outdated_browser'
......@@ -20,3 +20,4 @@
%li.visible-xs
= link_to "Sign in", new_session_path(:user, redirect_to_referer: 'yes')
= render 'shared/outdated_browser'
......@@ -6,6 +6,7 @@
.content
.login-title
%h1= brand_title
= render 'shared/outdated_browser'
%hr
.container
.content
......
- if outdated_browser?
- link = "https://gitlab.com/gitlab-org/gitlab-ce/blob/master/doc/install/requirements.md#supported-web-browsers"
.browser-alert
GitLab may not work properly because you are using an outdated web browser.
%br
Please install a
= link_to 'supported web browser', link
for a better experience.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment