Update hamlit to fix ruby 2.5 incompatibilities, fixes #42045

Also update the hook logs to escape the contents properly, as the :plain
filter does not do html escaping.
parent 96eb6fd3
...@@ -104,7 +104,7 @@ gem 'hashie-forbidden_attributes' ...@@ -104,7 +104,7 @@ gem 'hashie-forbidden_attributes'
gem 'kaminari', '~> 1.0' gem 'kaminari', '~> 1.0'
# HAML # HAML
gem 'hamlit', '~> 2.6.1' gem 'hamlit', '~> 2.8.8'
# Files attachments # Files attachments
gem 'carrierwave', '~> 1.2' gem 'carrierwave', '~> 1.2'
......
...@@ -381,8 +381,8 @@ GEM ...@@ -381,8 +381,8 @@ GEM
rake (>= 10, < 13) rake (>= 10, < 13)
rubocop (>= 0.49.0) rubocop (>= 0.49.0)
sysexits (~> 1.1) sysexits (~> 1.1)
hamlit (2.6.1) hamlit (2.8.8)
temple (~> 0.7.6) temple (>= 0.8.0)
thor thor
tilt tilt
hashdiff (0.3.4) hashdiff (0.3.4)
...@@ -889,7 +889,7 @@ GEM ...@@ -889,7 +889,7 @@ GEM
sys-filesystem (1.1.6) sys-filesystem (1.1.6)
ffi ffi
sysexits (1.2.0) sysexits (1.2.0)
temple (0.7.7) temple (0.8.0)
test-prof (0.2.5) test-prof (0.2.5)
test_after_commit (1.1.0) test_after_commit (1.1.0)
activerecord (>= 3.2) activerecord (>= 3.2)
...@@ -900,7 +900,7 @@ GEM ...@@ -900,7 +900,7 @@ GEM
rack (>= 1, < 3) rack (>= 1, < 3)
thor (0.19.4) thor (0.19.4)
thread_safe (0.3.6) thread_safe (0.3.6)
tilt (2.0.6) tilt (2.0.8)
timecop (0.8.1) timecop (0.8.1)
timfel-krb5-auth (0.8.3) timfel-krb5-auth (0.8.3)
toml (0.1.2) toml (0.1.2)
...@@ -1057,7 +1057,7 @@ DEPENDENCIES ...@@ -1057,7 +1057,7 @@ DEPENDENCIES
graphql (~> 1.8.0) graphql (~> 1.8.0)
grpc (~> 1.11.0) grpc (~> 1.11.0)
haml_lint (~> 0.26.0) haml_lint (~> 0.26.0)
hamlit (~> 2.6.1) hamlit (~> 2.8.8)
hashie-forbidden_attributes hashie-forbidden_attributes
health_check (~> 2.6.0) health_check (~> 2.6.0)
hipchat (~> 1.5.0) hipchat (~> 1.5.0)
......
...@@ -384,8 +384,8 @@ GEM ...@@ -384,8 +384,8 @@ GEM
rake (>= 10, < 13) rake (>= 10, < 13)
rubocop (>= 0.49.0) rubocop (>= 0.49.0)
sysexits (~> 1.1) sysexits (~> 1.1)
hamlit (2.6.1) hamlit (2.8.8)
temple (~> 0.7.6) temple (>= 0.8.0)
thor thor
tilt tilt
hashdiff (0.3.4) hashdiff (0.3.4)
...@@ -898,7 +898,7 @@ GEM ...@@ -898,7 +898,7 @@ GEM
sys-filesystem (1.1.6) sys-filesystem (1.1.6)
ffi ffi
sysexits (1.2.0) sysexits (1.2.0)
temple (0.7.7) temple (0.8.0)
test-prof (0.2.5) test-prof (0.2.5)
text (1.3.1) text (1.3.1)
thin (1.7.0) thin (1.7.0)
...@@ -1067,7 +1067,7 @@ DEPENDENCIES ...@@ -1067,7 +1067,7 @@ DEPENDENCIES
graphql (~> 1.8.0) graphql (~> 1.8.0)
grpc (~> 1.11.0) grpc (~> 1.11.0)
haml_lint (~> 0.26.0) haml_lint (~> 0.26.0)
hamlit (~> 2.6.1) hamlit (~> 2.8.8)
hashie-forbidden_attributes hashie-forbidden_attributes
health_check (~> 2.6.0) health_check (~> 2.6.0)
hipchat (~> 1.5.0) hipchat (~> 1.5.0)
......
...@@ -30,7 +30,7 @@ ...@@ -30,7 +30,7 @@
%h5 Request body: %h5 Request body:
%pre %pre
:plain :escaped
#{JSON.pretty_generate(hook_log.request_data)} #{JSON.pretty_generate(hook_log.request_data)}
%h5 Response headers: %h5 Response headers:
%pre %pre
...@@ -40,5 +40,5 @@ ...@@ -40,5 +40,5 @@
%h5 Response body: %h5 Response body:
%pre %pre
:plain :escaped
#{hook_log.response_body} #{hook_log.response_body}
---
title: 'Update hamlit to fix ruby 2.5 incompatibilities, fixes #42045'
merge_request:
author: Matthew Dawson
type: fixed
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment