Commit 4193e3d4 authored by Stan Hu's avatar Stan Hu

Bump fog-aws to 3.3.0 and associated dependencies

Fixes issue with AWS V4 signatures not working with Ceph S3:
https://github.com/fog/fog-aws/issues/462
parent d86de642
...@@ -94,13 +94,13 @@ gem 'carrierwave', '~> 1.3' ...@@ -94,13 +94,13 @@ gem 'carrierwave', '~> 1.3'
gem 'mini_magick' gem 'mini_magick'
# for backups # for backups
gem 'fog-aws', '~> 2.0.1' gem 'fog-aws', '~> 3.3'
gem 'fog-core', '~> 1.44' gem 'fog-core', '~> 2.1'
gem 'fog-google', '~> 1.7.1' gem 'fog-google', '~> 1.8'
gem 'fog-local', '~> 0.3' gem 'fog-local', '~> 0.6'
gem 'fog-openstack', '~> 0.1' gem 'fog-openstack', '~> 1.0'
gem 'fog-rackspace', '~> 0.1.1' gem 'fog-rackspace', '~> 0.1.1'
gem 'fog-aliyun', '~> 0.2.0' gem 'fog-aliyun', '~> 0.3'
# for Google storage # for Google storage
gem 'google-api-client', '~> 0.23' gem 'google-api-client', '~> 0.23'
......
...@@ -218,32 +218,33 @@ GEM ...@@ -218,32 +218,33 @@ GEM
flowdock (0.7.1) flowdock (0.7.1)
httparty (~> 0.7) httparty (~> 0.7)
multi_json multi_json
fog-aliyun (0.2.0) fog-aliyun (0.3.2)
fog-core (~> 1.27) fog-core
fog-json (~> 1.0) fog-json
ipaddress (~> 0.8) ipaddress (~> 0.8)
xml-simple (~> 1.1) xml-simple (~> 1.1)
fog-aws (2.0.1) fog-aws (3.3.0)
fog-core (~> 1.38) fog-core (~> 2.1)
fog-json (~> 1.0) fog-json (~> 1.1)
fog-xml (~> 0.1) fog-xml (~> 0.1)
ipaddress (~> 0.8) ipaddress (~> 0.8)
fog-core (1.45.0) fog-core (2.1.0)
builder builder
excon (~> 0.58) excon (~> 0.58)
formatador (~> 0.2) formatador (~> 0.2)
fog-google (1.7.1) mime-types
fog-core fog-google (1.8.2)
fog-json fog-core (<= 2.1.0)
fog-xml fog-json (~> 1.2)
fog-xml (~> 0.1.0)
google-api-client (~> 0.23.0) google-api-client (~> 0.23.0)
fog-json (1.0.2) fog-json (1.2.0)
fog-core (~> 1.0) fog-core
multi_json (~> 1.10) multi_json (~> 1.10)
fog-local (0.3.1) fog-local (0.6.0)
fog-core (~> 1.27) fog-core (>= 1.27, < 3.0)
fog-openstack (0.1.21) fog-openstack (1.0.8)
fog-core (>= 1.40) fog-core (~> 2.1)
fog-json (>= 1.0) fog-json (>= 1.0)
ipaddress (>= 0.8) ipaddress (>= 0.8)
fog-rackspace (0.1.1) fog-rackspace (0.1.1)
...@@ -1002,12 +1003,12 @@ DEPENDENCIES ...@@ -1002,12 +1003,12 @@ DEPENDENCIES
flipper-active_record (~> 0.13.0) flipper-active_record (~> 0.13.0)
flipper-active_support_cache_store (~> 0.13.0) flipper-active_support_cache_store (~> 0.13.0)
flowdock (~> 0.7) flowdock (~> 0.7)
fog-aliyun (~> 0.2.0) fog-aliyun (~> 0.3)
fog-aws (~> 2.0.1) fog-aws (~> 3.3)
fog-core (~> 1.44) fog-core (~> 2.1)
fog-google (~> 1.7.1) fog-google (~> 1.8)
fog-local (~> 0.3) fog-local (~> 0.6)
fog-openstack (~> 0.1) fog-openstack (~> 1.0)
fog-rackspace (~> 0.1.1) fog-rackspace (~> 0.1.1)
font-awesome-rails (~> 4.7) font-awesome-rails (~> 4.7)
foreman (~> 0.84.0) foreman (~> 0.84.0)
......
...@@ -112,7 +112,7 @@ describe SendFileUpload do ...@@ -112,7 +112,7 @@ describe SendFileUpload do
it 'sends a file with a custom type' do it 'sends a file with a custom type' do
headers = double headers = double
expected_headers = %r(response-content-disposition=attachment%3B%20filename%3D%22test.js%22%3B%20filename%2A%3DUTF-8%27%27test.js&response-content-type=application/ecmascript) expected_headers = /response-content-disposition=attachment%3B%20filename%3D%22test.js%22%3B%20filename%2A%3DUTF-8%27%27test.js&response-content-type=application%2Fecmascript/
expect(Gitlab::Workhorse).to receive(:send_url).with(expected_headers).and_call_original expect(Gitlab::Workhorse).to receive(:send_url).with(expected_headers).and_call_original
expect(headers).to receive(:store).with(Gitlab::Workhorse::SEND_DATA_HEADER, /^send-url:/) expect(headers).to receive(:store).with(Gitlab::Workhorse::SEND_DATA_HEADER, /^send-url:/)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment