Commit 216d21c5 authored by Tim Zallmann's avatar Tim Zallmann

Merge branch 'upgrade-frontend-build-dependencies' into 'master'

Upgrade frontend build dependencies

Closes #41400

See merge request gitlab-org/gitlab-ce!17246
parents 11bf575f b28aad78
......@@ -467,8 +467,8 @@
- - :license
- pikaday
- MIT
- :who:
:why:
- :who:
:why:
:versions: []
:when: 2017-10-17 17:46:12.367554000 Z
- - :license
......@@ -516,3 +516,21 @@
:why: zlib license + Development Lib + https://github.com/uNetworking/uWebSockets/blob/master/LICENSE
:versions: []
:when: 2018-01-17 23:46:12.367554000 Z
- - :approve
- atob
- :who: Mike Greiling
:why: https://github.com/node-browser-compat/atob/blob/master/LICENSE
:versions: []
:when: 2018-02-20 19:42:08.409887000 Z
- - :approve
- cyclist
- :who: Mike Greiling
:why: https://github.com/mafintosh/cyclist/blob/master/LICENSE
:versions: []
:when: 2018-02-20 21:37:43.774978000 Z
- - :approve
- bitsyntax
- :who: Mike Greiling
:why: https://github.com/squaremo/bitsyntax-js/blob/master/LICENSE-MIT
:versions: []
:when: 2018-02-20 22:20:25.958123000 Z
......@@ -16,7 +16,6 @@
"autosize": "^4.0.0",
"axios": "^0.17.1",
"babel-core": "^6.26.0",
"babel-eslint": "^8.0.2",
"babel-loader": "^7.1.2",
"babel-plugin-transform-define": "^1.3.0",
"babel-preset-latest": "^6.24.1",
......@@ -27,11 +26,11 @@
"chart.js": "1.0.2",
"classlist-polyfill": "^1.2.0",
"clipboard": "^1.7.1",
"compression-webpack-plugin": "^1.0.0",
"copy-webpack-plugin": "^4.0.1",
"compression-webpack-plugin": "^1.1.7",
"copy-webpack-plugin": "^4.4.1",
"core-js": "^2.4.1",
"cropper": "^2.3.0",
"css-loader": "^0.28.0",
"css-loader": "^0.28.9",
"d3-array": "^1.2.1",
"d3-axis": "^1.0.8",
"d3-brush": "^1.0.4",
......@@ -45,11 +44,11 @@
"document-register-element": "1.3.0",
"dropzone": "^4.2.0",
"emoji-unicode-version": "^0.2.1",
"exports-loader": "^0.6.4",
"file-loader": "^0.11.1",
"exports-loader": "^0.7.0",
"file-loader": "^1.1.8",
"fuzzaldrin-plus": "^0.5.0",
"glob": "^7.1.2",
"imports-loader": "^0.7.1",
"imports-loader": "^0.8.0",
"jed": "^1.1.1",
"jquery": "^3.2.1",
"jquery-ujs": "1.2.2",
......@@ -67,33 +66,34 @@
"raphael": "^2.2.7",
"raven-js": "^3.22.1",
"raw-loader": "^0.5.1",
"react-dev-utils": "^0.5.2",
"react-dev-utils": "^5.0.0",
"sanitize-html": "^1.16.1",
"select2": "3.5.2-browserify",
"sql.js": "^0.4.0",
"style-loader": "^0.19.1",
"style-loader": "^0.20.2",
"svg4everybody": "2.1.9",
"three": "^0.84.0",
"three-orbit-controls": "^82.1.0",
"three-stl-loader": "^1.0.4",
"timeago.js": "^3.0.2",
"underscore": "^1.8.3",
"url-loader": "^0.5.8",
"url-loader": "^0.6.2",
"visibilityjs": "^1.2.4",
"vue": "^2.5.13",
"vue-loader": "^13.7.0",
"vue-loader": "^14.1.1",
"vue-resource": "^1.3.5",
"vue-router": "^3.0.1",
"vue-template-compiler": "^2.5.13",
"vuex": "^3.0.1",
"webpack": "^3.5.5",
"webpack-bundle-analyzer": "^2.8.2",
"webpack": "^3.11.0",
"webpack-bundle-analyzer": "^2.10.0",
"webpack-stats-plugin": "^0.1.5",
"worker-loader": "^1.1.0"
},
"devDependencies": {
"@gitlab-org/gitlab-svgs": "^1.8.0",
"axios-mock-adapter": "^1.10.0",
"babel-eslint": "^8.0.2",
"babel-plugin-istanbul": "^4.1.5",
"eslint": "^3.18.0",
"eslint-config-airbnb-base": "^10.0.1",
......@@ -109,13 +109,13 @@
"jasmine-jquery": "^2.1.1",
"karma": "^2.0.0",
"karma-chrome-launcher": "^2.2.0",
"karma-coverage-istanbul-reporter": "^1.3.3",
"karma-coverage-istanbul-reporter": "^1.4.1",
"karma-jasmine": "^1.1.1",
"karma-mocha-reporter": "^2.2.5",
"karma-sourcemap-loader": "^0.3.7",
"karma-webpack": "2.0.7",
"nodemon": "^1.11.0",
"nodemon": "^1.15.1",
"prettier": "1.9.2",
"webpack-dev-server": "^2.6.1"
"webpack-dev-server": "^2.11.1"
}
}
This source diff could not be displayed because it is too large. You can view the blob instead.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment