Commit 20189f84 authored by Riyad Preukschas's avatar Riyad Preukschas

Update gems

parent 527d2236
......@@ -17,7 +17,7 @@ gem "pg", group: :postgres
# Auth
gem "devise", "~> 2.1.0"
gem 'omniauth'
gem 'omniauth', "~> 1.1.1"
gem 'omniauth-google-oauth2'
gem 'omniauth-twitter'
gem 'omniauth-github'
......@@ -27,7 +27,7 @@ gem "grit", git: "https://github.com/gitlabhq/grit.git", ref:
gem "omniauth-ldap", git: "https://github.com/gitlabhq/omniauth-ldap.git", ref: 'f038dd852d7bd473a557e385d5d7c2fd5dc1dc2e'
gem 'yaml_db', git: "https://github.com/gitlabhq/yaml_db.git", ref: '98e9a5dca43e3fedd3268c76a73af40d1bdf1dfd'
gem 'grack', git: "https://github.com/gitlabhq/grack.git", ref: 'ba46f3b0845c6a09d488ae6abdce6ede37e227e8'
gem 'grit_ext', git: "https://github.com/gitlabhq/grit_ext.git", ref: '212fd40bea61f3c6a167223768e7295dc32bbc10'
gem 'grit_ext', git: "https://github.com/gitlabhq/grit_ext.git", ref: '212fd40bea61f3c6a167223768e7295dc32bbc10'
# Gitolite client (for work with gitolite-admin repo)
gem "gitolite", '1.1.0'
......@@ -46,13 +46,13 @@ gem "grape", "~> 0.2.1"
gem "stamp"
# Pagination
gem "kaminari"
gem "kaminari", "~> 0.14.1"
# HAML
gem "haml-rails"
gem "haml-rails", "~> 0.3.5"
# Files attachments
gem "carrierwave"
gem "carrierwave", "~> 0.7.1"
# Authorization
gem "six"
......@@ -64,21 +64,21 @@ gem "ffaker"
gem "seed-fu"
# Markdown to HTML
gem "redcarpet", "~> 2.1.1"
gem "redcarpet", "~> 2.2.2"
gem "github-markup", "~> 0.7.4", require: 'github/markup'
# Servers
gem "thin", '~> 1.5.0'
gem "unicorn"
gem "unicorn", "~> 4.4.0"
# Issue tags
gem "acts-as-taggable-on", "2.3.1"
gem "acts-as-taggable-on", "2.3.3"
# Decorators
gem "draper"
gem "draper", "~> 0.18.0"
# Background jobs
gem "resque", "~> 1.20.0"
gem "resque", "~> 1.23.0"
gem 'resque_mailer'
# HTTP requests
......@@ -87,34 +87,34 @@ gem "httparty"
# Colored output to console
gem "colored"
# GITLAB settings
# GitLab settings
gem 'settingslogic'
# Misc
gem "foreman"
gem 'gemoji', require: 'emoji/railtie'
gem "git"
group :assets do
gem "sass-rails", "3.2.5"
gem "coffee-rails", "3.2.2"
gem "uglifier", "1.0.3"
gem "sass-rails", "~> 3.2.5"
gem "coffee-rails", "~> 3.2.2"
gem "uglifier", "~> 1.3.0"
gem "therubyracer"
gem 'chosen-rails'
gem 'jquery-atwho-rails', '0.1.6'
gem "jquery-rails", "2.0.2"
gem "jquery-ui-rails", "0.5.0"
gem "modernizr", "2.5.3"
gem "raphael-rails", "1.5.2"
gem 'chosen-rails', "0.9.8"
gem 'jquery-atwho-rails', "0.1.6"
gem "jquery-rails", "2.1.3"
gem "jquery-ui-rails", "2.0.2"
gem "modernizr", "2.6.2"
gem "raphael-rails", "2.1.0"
gem 'bootstrap-sass', "2.0.4"
gem "font-awesome-sass-rails", "~> 2.0.0"
gem "gemoji", "~> 1.2.1", require: 'emoji/railtie'
end
group :development do
gem "annotate", git: "https://github.com/ctran/annotate_models.git"
gem "letter_opener"
gem 'quiet_assets', '1.0.1'
gem 'quiet_assets', '~> 1.0.1'
gem 'rack-mini-profiler'
end
......@@ -144,7 +144,7 @@ end
group :test do
gem "simplecov", require: false
gem "shoulda-matchers"
gem "shoulda-matchers", "1.3.0"
gem 'email_spec'
gem 'resque_spec'
gem "webmock"
......
GIT
remote: https://github.com/ctran/annotate_models.git
revision: 18cd39ad01829deba5aa34634b8540d6675ab978
revision: be4e26825b521f0b2d86b181e2dff89901aa9b1e
specs:
annotate (2.4.1.beta1)
annotate (2.6.0.beta1)
activerecord (>= 2.3.0)
rake (>= 0.8.7)
GIT
remote: https://github.com/gitlabhq/grack.git
......@@ -87,78 +89,79 @@ GEM
activesupport (3.2.9)
i18n (~> 0.6)
multi_json (~> 1.0)
acts-as-taggable-on (2.3.1)
acts-as-taggable-on (2.3.3)
rails (~> 3.0)
addressable (2.2.8)
addressable (2.3.2)
arel (3.0.2)
awesome_print (1.0.2)
awesome_print (1.1.0)
backports (2.6.5)
bcrypt-ruby (3.0.1)
blankslate (2.1.2.4)
blankslate (3.1.2)
bootstrap-sass (2.0.4.0)
builder (3.0.4)
capybara (1.1.2)
capybara (1.1.3)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
carrierwave (0.6.2)
carrierwave (0.7.1)
activemodel (>= 3.2.0)
activesupport (>= 3.2.0)
charlock_holmes (0.6.9)
childprocess (0.3.2)
ffi (~> 1.0.6)
chosen-rails (0.9.8.3)
childprocess (0.3.6)
ffi (~> 1.0, >= 1.0.6)
chosen-rails (0.9.8)
railties (~> 3.0)
thor (~> 0.14)
coderay (1.0.6)
coderay (1.0.8)
coffee-rails (3.2.2)
coffee-script (>= 2.2.0)
railties (~> 3.2.0)
coffee-script (2.2.0)
coffee-script-source
execjs
coffee-script-source (1.3.3)
coffee-script-source (1.4.0)
colored (1.2)
colorize (0.5.8)
crack (0.3.1)
daemons (1.1.9)
database_cleaner (0.8.0)
database_cleaner (0.9.1)
devise (2.1.2)
bcrypt-ruby (~> 3.0)
orm_adapter (~> 0.1)
railties (~> 3.1)
warden (~> 1.2.1)
diff-lcs (1.1.3)
draper (0.17.0)
draper (0.18.0)
actionpack (~> 3.2)
activesupport (~> 3.2)
email_spec (1.2.1)
email_spec (1.4.0)
launchy (~> 2.1)
mail (~> 2.2)
rspec (~> 2.0)
erubis (2.7.0)
escape_utils (0.2.4)
eventmachine (1.0.0)
execjs (1.4.0)
multi_json (~> 1.0)
factory_girl (4.0.0)
factory_girl (4.1.0)
activesupport (>= 3.0.0)
factory_girl_rails (4.0.0)
factory_girl (~> 4.0.0)
factory_girl_rails (4.1.0)
factory_girl (~> 4.1.0)
railties (>= 3.0.0)
faraday (0.8.4)
multipart-post (~> 1.1)
faye-websocket (0.4.6)
eventmachine (>= 0.12.0)
ffaker (1.14.0)
ffi (1.0.11)
ffaker (1.15.0)
ffi (1.1.5)
font-awesome-sass-rails (2.0.0.0)
railties (>= 3.1.1)
sass-rails (>= 3.1.1)
foreman (0.47.0)
foreman (0.60.2)
thor (>= 0.13.6)
gemoji (1.1.1)
gemoji (1.2.1)
gherkin-ruby (0.2.1)
git (1.2.5)
github-linguist (2.3.4)
......@@ -172,75 +175,82 @@ GEM
gratr19 (~> 0.4.4.1)
grit (~> 2.5.0)
hashery (~> 1.5.0)
grape (0.2.1)
grape (0.2.2)
activesupport
hashie (~> 1.2)
multi_json
multi_json (>= 1.3.2)
multi_xml
rack
rack-accept
rack-mount
virtus
gratr19 (0.4.4.1)
growl (1.0.3)
guard (1.3.2)
guard (1.5.4)
listen (>= 0.4.2)
lumberjack (>= 1.0.2)
pry (>= 0.9.10)
thor (>= 0.14.6)
guard-rspec (1.2.1)
guard-rspec (2.1.2)
guard (>= 1.1)
rspec (~> 2.11)
guard-spinach (0.0.2)
guard (>= 1.1)
spinach
haml (3.1.6)
haml-rails (0.3.4)
actionpack (~> 3.0)
activesupport (~> 3.0)
haml (~> 3.0)
railties (~> 3.0)
haml (3.1.7)
haml-rails (0.3.5)
actionpack (>= 3.1, < 4.1)
activesupport (>= 3.1, < 4.1)
haml (~> 3.1)
railties (>= 3.1, < 4.1)
hashery (1.5.0)
blankslate
hashie (1.2.0)
hike (1.2.1)
http_parser.rb (0.5.3)
httparty (0.8.3)
httparty (0.9.0)
multi_json (~> 1.0)
multi_xml
httpauth (0.1)
httpauth (0.2.0)
i18n (0.6.1)
journey (1.0.4)
jquery-atwho-rails (0.1.6)
jquery-rails (2.0.2)
railties (>= 3.2.0, < 5.0)
jquery-rails (2.1.3)
railties (>= 3.1.0, < 5.0)
thor (~> 0.14)
jquery-ui-rails (0.5.0)
jquery-ui-rails (2.0.2)
jquery-rails
railties (>= 3.1.0)
json (1.7.5)
jwt (0.1.5)
multi_json (>= 1.0)
kaminari (0.14.0)
kaminari (0.14.1)
actionpack (>= 3.0.0)
activesupport (>= 3.0.0)
kgio (2.7.4)
launchy (2.1.0)
addressable (~> 2.2.6)
letter_opener (0.0.2)
launchy
launchy (2.1.2)
addressable (~> 2.3)
letter_opener (1.0.0)
launchy (>= 2.0.4)
libv8 (3.3.10.4)
libwebsocket (0.1.3)
addressable
listen (0.5.0)
libwebsocket (0.1.6)
websocket
listen (0.5.3)
lumberjack (1.0.2)
mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
method_source (0.7.1)
method_source (0.8.1)
mime-types (1.19)
modernizr (2.5.3)
modernizr (2.6.2)
sprockets (~> 2.0)
multi_json (1.3.7)
multi_xml (0.5.1)
multipart-post (1.1.5)
mysql2 (0.3.11)
net-ldap (0.2.2)
nokogiri (1.5.3)
nokogiri (1.5.5)
oauth (0.4.7)
oauth2 (0.8.0)
faraday (~> 0.8)
......@@ -248,7 +258,7 @@ GEM
jwt (~> 0.1.4)
multi_json (~> 1.0)
rack (~> 1.2)
omniauth (1.1.0)
omniauth (1.1.1)
hashie (~> 1.2)
rack
omniauth-github (1.0.3)
......@@ -260,14 +270,14 @@ GEM
omniauth-oauth (1.0.1)
oauth
omniauth (~> 1.0)
omniauth-oauth2 (1.1.0)
omniauth-oauth2 (1.1.1)
oauth2 (~> 0.8.0)
omniauth (~> 1.0)
omniauth-twitter (0.0.13)
omniauth-twitter (0.0.14)
multi_json (~> 1.3)
omniauth-oauth (~> 1.0)
orm_adapter (0.3.0)
pg (0.14.0)
orm_adapter (0.4.0)
pg (0.14.1)
poltergeist (1.0.2)
capybara (~> 1.1)
childprocess (~> 0.3)
......@@ -276,17 +286,19 @@ GEM
multi_json (~> 1.0)
polyglot (0.3.3)
posix-spawn (0.3.6)
pry (0.9.9.6)
pry (0.9.10)
coderay (~> 1.0.5)
method_source (~> 0.7.1)
slop (>= 2.4.4, < 3)
method_source (~> 0.8)
slop (~> 3.3.1)
pyu-ruby-sasl (0.0.3.3)
quiet_assets (1.0.1)
railties (~> 3.1)
rack (1.4.1)
rack-accept (0.4.5)
rack (>= 0.4)
rack-cache (1.2)
rack (>= 0.4)
rack-mini-profiler (0.1.9)
rack-mini-profiler (0.1.23)
rack (>= 1.1.3)
rack-mount (0.8.3)
rack (>= 1.0.0)
......@@ -314,45 +326,46 @@ GEM
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
raindrops (0.9.0)
rake (10.0.0)
raphael-rails (1.5.2)
rb-fsevent (0.9.1)
raindrops (0.10.0)
rake (10.0.1)
raphael-rails (2.1.0)
rb-fsevent (0.9.2)
rb-inotify (0.8.8)
ffi (>= 0.5.0)
rdoc (3.12)
json (~> 1.4)
redcarpet (2.1.1)
redis (2.2.2)
redis-namespace (1.0.3)
redis (< 3.0.0)
resque (1.20.0)
redcarpet (2.2.2)
redis (3.0.2)
redis-namespace (1.2.1)
redis (~> 3.0.0)
resque (1.23.0)
multi_json (~> 1.0)
redis-namespace (~> 1.0.2)
redis-namespace (~> 1.0)
sinatra (>= 0.9.2)
vegas (~> 0.1.2)
resque_mailer (2.0.3)
actionmailer (>= 3.0.0)
resque (>= 1.2.3)
resque_spec (0.11.0)
resque_mailer (2.1.0)
actionmailer (~> 3.0)
resque_spec (0.12.5)
resque (>= 1.19.0)
rspec (>= 2.5.0)
rspec (2.10.0)
rspec-core (~> 2.10.0)
rspec-expectations (~> 2.10.0)
rspec-mocks (~> 2.10.0)
rspec-core (2.10.1)
rspec-expectations (2.10.0)
rspec (2.12.0)
rspec-core (~> 2.12.0)
rspec-expectations (~> 2.12.0)
rspec-mocks (~> 2.12.0)
rspec-core (2.12.0)
rspec-expectations (2.12.0)
diff-lcs (~> 1.1.3)
rspec-mocks (2.10.1)
rspec-rails (2.10.1)
rspec-mocks (2.12.0)
rspec-rails (2.12.0)
actionpack (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
rspec (~> 2.10.0)
rspec-core (~> 2.12.0)
rspec-expectations (~> 2.12.0)
rspec-mocks (~> 2.12.0)
rubyntlm (0.1.1)
rubyzip (0.9.8)
sass (3.1.19)
rubyzip (0.9.9)
sass (3.2.3)
sass-rails (3.2.5)
railties (~> 3.2.0)
sass (>= 3.1.10)
......@@ -360,25 +373,24 @@ GEM
seed-fu (2.2.0)
activerecord (~> 3.1)
activesupport (~> 3.1)
selenium-webdriver (2.22.2)
selenium-webdriver (2.26.0)
childprocess (>= 0.2.5)
ffi (~> 1.0)
libwebsocket (~> 0.1.3)
multi_json (~> 1.0)
rubyzip
settingslogic (2.0.8)
shoulda-matchers (1.3.0)
activesupport (>= 3.0.0)
simplecov (0.6.4)
simplecov (0.7.1)
multi_json (~> 1.0)
simplecov-html (~> 0.5.3)
simplecov-html (0.5.3)
sinatra (1.3.2)
simplecov-html (~> 0.7.1)
simplecov-html (0.7.1)
sinatra (1.3.3)
rack (~> 1.3, >= 1.3.6)
rack-protection (~> 1.2)
tilt (~> 1.3, >= 1.3.3)
six (0.2.0)
slop (2.4.4)
slop (3.3.3)
spinach (0.5.2)
colorize
gherkin-ruby (~> 0.2.0)
......@@ -392,9 +404,9 @@ GEM
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sqlite3 (1.3.6)
stamp (0.1.6)
stamp (0.3.0)
test_after_commit (0.0.1)
therubyracer (0.10.1)
therubyracer (0.10.2)
libv8 (~> 3.3.10)
thin (1.5.0)
daemons (>= 1.0.9)
......@@ -406,20 +418,23 @@ GEM
polyglot
polyglot (>= 0.3.1)
tzinfo (0.3.35)
uglifier (1.0.3)
uglifier (1.3.0)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
unicorn (4.3.1)
multi_json (~> 1.0, >= 1.0.2)
unicorn (4.4.0)
kgio (~> 2.6)
rack
raindrops (~> 0.7)
vegas (0.1.11)
rack (>= 1.0.0)
virtus (0.5.2)
backports (~> 2.6.1)
warden (1.2.1)
rack (>= 1.0)
webmock (1.8.7)
webmock (1.9.0)
addressable (>= 2.2.7)
crack (>= 0.1.7)
websocket (1.0.2)
xpath (0.1.4)
nokogiri (~> 1.3)
yajl-ruby (1.1.0)
......@@ -428,24 +443,24 @@ PLATFORMS
ruby
DEPENDENCIES
acts-as-taggable-on (= 2.3.1)
acts-as-taggable-on (= 2.3.3)
annotate!
awesome_print
bootstrap-sass (= 2.0.4)
capybara
carrierwave
chosen-rails
coffee-rails (= 3.2.2)
carrierwave (~> 0.7.1)
chosen-rails (= 0.9.8)
coffee-rails (~> 3.2.2)
colored
database_cleaner
devise (~> 2.1.0)
draper
draper (~> 0.18.0)
email_spec
factory_girl_rails
ffaker
font-awesome-sass-rails (~> 2.0.0)
foreman
gemoji
gemoji (~> 1.2.1)
git
github-linguist (~> 2.3.4)
github-markup (~> 0.7.4)
......@@ -458,17 +473,17 @@ DEPENDENCIES
growl
guard-rspec
guard-spinach
haml-rails
haml-rails (~> 0.3.5)
httparty
jquery-atwho-rails (= 0.1.6)
jquery-rails (= 2.0.2)
jquery-ui-rails (= 0.5.0)
kaminari
jquery-rails (= 2.1.3)
jquery-ui-rails (= 2.0.2)
kaminari (~> 0.14.1)
launchy
letter_opener
modernizr (= 2.5.3)
modernizr (= 2.6.2)
mysql2
omniauth
omniauth (~> 1.1.1)
omniauth-github
omniauth-google-oauth2
omniauth-ldap!
......@@ -477,22 +492,22 @@ DEPENDENCIES
poltergeist
pry
pygments.rb!
quiet_assets (= 1.0.1)
quiet_assets (~> 1.0.1)
rack-mini-profiler
rails (= 3.2.9)
rails-dev-tweaks
raphael-rails (= 1.5.2)
raphael-rails (= 2.1.0)
rb-fsevent
rb-inotify
redcarpet (~> 2.1.1)
resque (~> 1.20.0)
redcarpet (~> 2.2.2)
resque (~> 1.23.0)
resque_mailer
resque_spec
rspec-rails
sass-rails (= 3.2.5)
sass-rails (~> 3.2.5)
seed-fu
settingslogic
shoulda-matchers
shoulda-matchers (= 1.3.0)
simplecov
six
spinach-rails
......@@ -501,7 +516,7 @@ DEPENDENCIES
test_after_commit
therubyracer
thin (~> 1.5.0)
uglifier (= 1.0.3)
unicorn
uglifier (~> 1.3.0)
unicorn (~> 4.4.0)
webmock
yaml_db!
# Workaround for https://github.com/github/gemoji/pull/18
Gitlab::Application.config.assets.paths << Emoji.images_path
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment