Commit f7f9b1f2 authored by Stan Hu's avatar Stan Hu
Browse files

Add byebug to GitLab QA gem list for debugging

parent 5a23af92
source 'https://rubygems.org' source 'https://rubygems.org'
gem 'pry-byebug', '~> 3.4.1', platform: :mri
gem 'capybara', '~> 2.12.1' gem 'capybara', '~> 2.12.1'
gem 'capybara-screenshot', '~> 1.0.14' gem 'capybara-screenshot', '~> 1.0.14'
gem 'rake', '~> 12.0.0' gem 'rake', '~> 12.0.0'
......
...@@ -3,6 +3,7 @@ GEM ...@@ -3,6 +3,7 @@ GEM
specs: specs:
addressable (2.5.0) addressable (2.5.0)
public_suffix (~> 2.0, >= 2.0.2) public_suffix (~> 2.0, >= 2.0.2)
byebug (9.0.6)
capybara (2.12.1) capybara (2.12.1)
addressable addressable
mime-types (>= 1.16) mime-types (>= 1.16)
...@@ -13,22 +14,27 @@ GEM ...@@ -13,22 +14,27 @@ GEM
capybara-screenshot (1.0.14) capybara-screenshot (1.0.14)
capybara (>= 1.0, < 3) capybara (>= 1.0, < 3)
launchy launchy
capybara-webkit (1.12.0)
capybara (>= 2.3.0, < 2.13.0)
json
childprocess (0.7.0) childprocess (0.7.0)
ffi (~> 1.0, >= 1.0.11) ffi (~> 1.0, >= 1.0.11)
coderay (1.1.1)
diff-lcs (1.3) diff-lcs (1.3)
ffi (1.9.18) ffi (1.9.18)
json (2.0.3)
launchy (2.4.3) launchy (2.4.3)
addressable (~> 2.3) addressable (~> 2.3)
method_source (0.8.2)
mime-types (3.1) mime-types (3.1)
mime-types-data (~> 3.2015) mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521) mime-types-data (3.2016.0521)
mini_portile2 (2.1.0) mini_portile2 (2.1.0)
nokogiri (1.7.0.1) nokogiri (1.7.0.1)
mini_portile2 (~> 2.1.0) mini_portile2 (~> 2.1.0)
pry (0.10.4)
coderay (~> 1.1.0)
method_source (~> 0.8.1)
slop (~> 3.4)
pry-byebug (3.4.2)
byebug (~> 9.0)
pry (~> 0.10)
public_suffix (2.0.5) public_suffix (2.0.5)
rack (2.0.1) rack (2.0.1)
rack-test (0.6.3) rack-test (0.6.3)
...@@ -52,6 +58,7 @@ GEM ...@@ -52,6 +58,7 @@ GEM
childprocess (~> 0.5) childprocess (~> 0.5)
rubyzip (~> 1.0) rubyzip (~> 1.0)
websocket (~> 1.0) websocket (~> 1.0)
slop (3.6.0)
websocket (1.2.4) websocket (1.2.4)
xpath (2.0.0) xpath (2.0.0)
nokogiri (~> 1.3) nokogiri (~> 1.3)
...@@ -62,7 +69,7 @@ PLATFORMS ...@@ -62,7 +69,7 @@ PLATFORMS
DEPENDENCIES DEPENDENCIES
capybara (~> 2.12.1) capybara (~> 2.12.1)
capybara-screenshot (~> 1.0.14) capybara-screenshot (~> 1.0.14)
capybara-webkit (~> 1.12.0) pry-byebug (~> 3.4.1)
rake (~> 12.0.0) rake (~> 12.0.0)
rspec (~> 3.5) rspec (~> 3.5)
selenium-webdriver (~> 2.53) selenium-webdriver (~> 2.53)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment