Commit e961f3da authored by Nick Thomas's avatar Nick Thomas

Minimum postgresql version is now 9.2

parent 8f2af757
...@@ -52,7 +52,7 @@ stages: ...@@ -52,7 +52,7 @@ stages:
.use-pg: &use-pg .use-pg: &use-pg
services: services:
- postgres:9.1 - postgres:9.2
- redis:alpine - redis:alpine
.use-mysql: &use-mysql .use-mysql: &use-mysql
......
---
title: Minimum postgresql version is now 9.2
merge_request: 11677
author:
...@@ -281,5 +281,5 @@ GitLab database to `longtext` columns, which can persist values of up to 4GB ...@@ -281,5 +281,5 @@ GitLab database to `longtext` columns, which can persist values of up to 4GB
Details can be found in the [PostgreSQL][postgres-text-type] and Details can be found in the [PostgreSQL][postgres-text-type] and
[MySQL][mysql-text-types] manuals. [MySQL][mysql-text-types] manuals.
[postgres-text-type]: http://www.postgresql.org/docs/9.1/static/datatype-character.html [postgres-text-type]: http://www.postgresql.org/docs/9.2/static/datatype-character.html
[mysql-text-types]: http://dev.mysql.com/doc/refman/5.7/en/string-type-overview.html [mysql-text-types]: http://dev.mysql.com/doc/refman/5.7/en/string-type-overview.html
...@@ -185,7 +185,8 @@ Create a `git` user for GitLab: ...@@ -185,7 +185,8 @@ Create a `git` user for GitLab:
We recommend using a PostgreSQL database. For MySQL check the We recommend using a PostgreSQL database. For MySQL check the
[MySQL setup guide](database_mysql.md). [MySQL setup guide](database_mysql.md).
> **Note**: because we need to make use of extensions you need at least pgsql 9.1. > **Note**: because we need to make use of extensions and concurrent index removal,
you need at least PostgreSQL 9.2.
1. Install the database packages: 1. Install the database packages:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment