Commit cfc9bff4 authored by Martins Polakovs's avatar Martins Polakovs

Fix upgrader script

parent f042b085
......@@ -6,6 +6,7 @@ v 7.12.0 (unreleased)
- Update Asciidoctor gem to version 1.5.2. (Jakub Jirutka)
- Fix resolving of relative links to repository files in AsciiDoc documents. (Jakub Jirutka)
- Use the user list from the target project in a merge request (Stan Hu)
- Fix upgrader script (Martins Polakovs)
v 7.11.2
- no changes
......
......@@ -43,10 +43,15 @@ def current_version_raw
end
def latest_version_raw
git_tags = fetch_git_tags
git_tags = git_tags.select { |version| version =~ /v\d+\.\d+\.\d+\Z/ }
git_versions = git_tags.map { |tag| Gitlab::VersionInfo.parse(tag.match(/v\d+\.\d+\.\d+/).to_s) }
"v#{git_versions.sort.last.to_s}"
end
def fetch_git_tags
remote_tags, _ = Gitlab::Popen.popen(%W(git ls-remote --tags https://gitlab.com/gitlab-org/gitlab-ce.git))
git_tags = remote_tags.split("\n").grep(/tags\/v#{current_version.major}/)
git_tags = git_tags.select { |version| version =~ /v\d\.\d\.\d\Z/ }
last_tag = git_tags.last.match(/v\d\.\d\.\d/).to_s
remote_tags.split("\n").grep(/tags\/v#{current_version.major}/)
end
def update_commands
......
......@@ -20,5 +20,20 @@
upgrader.stub(current_version_raw: "5.3.0")
expect(upgrader.latest_version_raw).to eq("v5.4.2")
end
it 'should get the latest version from tags' do
upgrader.stub(fetch_git_tags: [
'6f0733310546402c15d3ae6128a95052f6c8ea96 refs/tags/v7.1.1',
'facfec4b242ce151af224e20715d58e628aa5e74 refs/tags/v7.1.1^{}',
'f7068d99c79cf79befbd388030c051bb4b5e86d4 refs/tags/v7.10.4',
'337225a4fcfa9674e2528cb6d41c46556bba9dfa refs/tags/v7.10.4^{}',
'880e0ba0adbed95d087f61a9a17515e518fc6440 refs/tags/v7.11.1',
'6584346b604f981f00af8011cd95472b2776d912 refs/tags/v7.11.1^{}',
'43af3e65a486a9237f29f56d96c3b3da59c24ae0 refs/tags/v7.11.2',
'dac18e7728013a77410e926a1e64225703754a2d refs/tags/v7.11.2^{}',
'0bf21fd4b46c980c26fd8c90a14b86a4d90cc950 refs/tags/v7.9.4',
'b10de29edbaff7219547dc506cb1468ee35065c3 refs/tags/v7.9.4^{}'])
expect(upgrader.latest_version_raw).to eq("v7.11.2")
end
end
end
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment