Commit 94915f97 authored by Robert Speicher's avatar Robert Speicher
Browse files

Merge branch 'gitlab-ce-fix/revert-ruby-2.2' into 'master'

revert back to ruby 2.1

- - -

Revert Ruby 2.2 changes - until we solve https://gitlab.com/gitlab-org/gitlab-ce/issues/13514

This also updates Ruby 2.1.7 to 2.1.8

See merge request !2898
parents a5c7aea3 af0ba660
image: "ruby:2.2"
image: "ruby:2.1"
services:
- mysql:latest
......@@ -6,7 +6,7 @@ services:
- redis:latest
cache:
key: "ruby22"
key: "ruby21"
paths:
- vendor
......@@ -140,87 +140,87 @@ bundler:audit:
- mysql
allow_failure: true
# Ruby 2.1 jobs
# Ruby 2.2 jobs
spec:feature:ruby21:
image: ruby:2.1
spec:feature:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test bundle exec rake assets:precompile 2>/dev/null
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spec:feature
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
- ruby
- mysql
spec:api:ruby21:
image: ruby:2.1
spec:api:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spec:api
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
- ruby
- mysql
spec:models:ruby21:
image: ruby:2.1
spec:models:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spec:models
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
- ruby
- mysql
spec:lib:ruby21:
image: ruby:2.1
spec:lib:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spec:lib
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
- ruby
- mysql
spec:services:ruby21:
image: ruby:2.1
spec:services:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spec:services
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
- ruby
- mysql
spec:benchmark:ruby21:
image: ruby:2.1
spec:benchmark:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test bundle exec rake spec:benchmark
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
......@@ -228,56 +228,56 @@ spec:benchmark:ruby21:
- mysql
allow_failure: true
spec:other:ruby21:
image: ruby:2.1
spec:other:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spec:other
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
- ruby
- mysql
spinach:project:half:ruby21:
image: ruby:2.1
spinach:project:half:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spinach:project:half
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
- ruby
- mysql
spinach:project:rest:ruby21:
image: ruby:2.1
spinach:project:rest:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spinach:project:rest
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
- ruby
- mysql
spinach:other:ruby21:
image: ruby:2.1
spinach:other:ruby22:
image: ruby:2.2
only:
- master
script:
- RAILS_ENV=test SIMPLECOV=true bundle exec rake spinach:other
cache:
key: "ruby21"
key: "ruby22"
paths:
- vendor
tags:
......
......@@ -67,7 +67,7 @@ Instructions on how to start GitLab and how to run the tests can be found in the
GitLab is a Ruby on Rails application that runs on the following software:
- Ubuntu/Debian/CentOS/RHEL
- Ruby (MRI) 2.1 or 2.2
- Ruby (MRI) 2.1
- Git 1.7.10+
- Redis 2.8+
- MySQL or PostgreSQL
......
......@@ -33,7 +33,7 @@ The YAML syntax allows for using more complex job specifications than in the
above example:
```yaml
image: ruby:2.2
image: ruby:2.1
services:
- postgres
......
......@@ -26,7 +26,7 @@ We use [these build scripts](https://gitlab.com/gitlab-org/gitlab-ci/blob/master
# Build configuration on [Semaphore](https://semaphoreapp.com/gitlabhq/gitlabhq/) for testing the [GitHub.com repo](https://github.com/gitlabhq/gitlabhq)
- Language: Ruby
- Ruby version: 2.2.4
- Ruby version: 2.1.8
- database.yml: pg
Build commands
......
......@@ -107,7 +107,7 @@ Then select 'Internet Site' and press enter to confirm the hostname.
## 2. Ruby
_**Note:** The current supported Ruby versions are 2.1.x and 2.2.x. Ruby 2.3 is
_**Note:** The current supported Ruby version is 2.1.x. Ruby 2.2 and 2.3 are
currently not supported._
The use of Ruby version managers such as [RVM], [rbenv] or [chruby] with GitLab
......@@ -123,9 +123,9 @@ Remove the old Ruby 1.8 if present:
Download Ruby and compile it:
mkdir /tmp/ruby && cd /tmp/ruby
curl -O --progress https://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.4.tar.gz
echo 'b6eff568b48e0fda76e5a36333175df049b204e91217aa32a65153cc0cdcb761 ruby-2.2.4.tar.gz' | sha256sum -c - && tar xzf ruby-2.2.4.tar.gz
cd ruby-2.2.4
curl -O --progress https://cache.ruby-lang.org/pub/ruby/2.1/ruby-2.1.8.tar.gz
echo 'c7e50159357afd87b13dc5eaf4ac486a70011149 ruby-2.1.8.tar.gz' | shasum -c - && tar xzf ruby-2.1.8.tar.gz
cd ruby-2.1.8
./configure --disable-install-rdoc
make
sudo make install
......
......@@ -32,7 +32,7 @@ Please consider using a virtual machine to run GitLab.
## Ruby versions
GitLab requires Ruby (MRI) 2.1.x or 2.2.x and currently does not work with version 2.3.
GitLab requires Ruby (MRI) 2.1.x and currently does not work with versions 2.2 or 2.3.
You will have to use the standard MRI implementation of Ruby.
We love [JRuby](http://jruby.org/) and [Rubinius](http://rubini.us/) but GitLab
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment