Commit 2994de75 authored by Zeger-Jan van de Weg's avatar Zeger-Jan van de Weg Committed by Rémy Coutable
Browse files

Upgrade Ruby to 2.3.5

Part of gitlab-org/gitlab-ce#38040
parent c598283a
image: "dev.gitlab.org:5005/gitlab/gitlab-build-images:ruby-2.3.3-golang-1.8-git-2.13-phantomjs-2.1-node-8.x-yarn-1.0-postgresql-9.6" image: "dev.gitlab.org:5005/gitlab/gitlab-build-images:ruby-2.3.5-golang-1.8-git-2.13-phantomjs-2.1-node-8.x-yarn-1.0-postgresql-9.6"
.default-cache: &default-cache .default-cache: &default-cache
key: "ruby-233-with-yarn" key: "ruby-235-with-yarn"
paths: paths:
- vendor/ruby - vendor/ruby
- .yarn-cache/ - .yarn-cache/
...@@ -551,7 +551,7 @@ karma: ...@@ -551,7 +551,7 @@ karma:
<<: *dedicated-runner <<: *dedicated-runner
<<: *except-docs <<: *except-docs
<<: *pull-cache <<: *pull-cache
image: "dev.gitlab.org:5005/gitlab/gitlab-build-images:ruby-2.3.3-golang-1.8-git-2.13-chrome-61.0-node-8.x-yarn-1.0-postgresql-9.6" image: "dev.gitlab.org:5005/gitlab/gitlab-build-images:ruby-2.3.5-golang-1.8-git-2.13-chrome-61.0-node-8.x-yarn-1.0-postgresql-9.6"
stage: test stage: test
variables: variables:
BABEL_ENV: "coverage" BABEL_ENV: "coverage"
......
---
title: Upgrade Ruby to 2.3.5 to include security patches
merge_request: 15099
author:
type: security
...@@ -5,7 +5,7 @@ class RubyVersionCheck < SystemCheck::BaseCheck ...@@ -5,7 +5,7 @@ class RubyVersionCheck < SystemCheck::BaseCheck
set_check_pass -> { "yes (#{self.current_version})" } set_check_pass -> { "yes (#{self.current_version})" }
def self.required_version def self.required_version
@required_version ||= Gitlab::VersionInfo.new(2, 3, 3) @required_version ||= Gitlab::VersionInfo.new(2, 3, 5)
end end
def self.current_version def self.current_version
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment