Commit 1d241206 authored by Chris Baumbauer's avatar Chris Baumbauer
Browse files

Upgrade Knative from 0.1.3 to 0.2.2

parent 185f8a5d
......@@ -3,7 +3,7 @@
module Clusters
module Applications
class Knative < ActiveRecord::Base
VERSION = '0.1.3'.freeze
VERSION = '0.2.2'.freeze
REPOSITORY = 'https://storage.googleapis.com/triggermesh-charts'.freeze
FETCH_IP_ADDRESS_DELAY = 30.seconds
......
---
title: Knative version bump 0.1.3 -> 0.2.2
merge_request:
author: Chris Baumbauer
type: changed
......@@ -33,10 +33,10 @@
end
context 'application install previously errored with older version' do
let(:application) { create(:clusters_applications_knative, :scheduled, version: '0.1.3') }
let(:application) { create(:clusters_applications_knative, :scheduled, version: '0.2.2') }
it 'updates the application version' do
expect(application.reload.version).to eq('0.1.3')
expect(application.reload.version).to eq('0.2.2')
end
end
end
......@@ -105,7 +105,7 @@
it 'should be initialized with knative arguments' do
expect(subject.name).to eq('knative')
expect(subject.chart).to eq('knative/knative')
expect(subject.version).to eq('0.1.3')
expect(subject.version).to eq('0.2.2')
expect(subject.files).to eq(knative.files)
end
end
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment