Commit 632189e0 authored by Daniel Gerhardt's avatar Daniel Gerhardt

Update Maven dependencies

Spring Framework has been upgraded to version 4.1.x along with other
dependencies.
parent cb99153c
......@@ -7,9 +7,10 @@
<packaging>war</packaging>
<properties>
<org.springframework-version>4.0.9.RELEASE</org.springframework-version>
<!-- Tests currently fail with Spring Framework >= 4.1.5 -->
<org.springframework-version>4.1.4.RELEASE</org.springframework-version>
<org.springframework.security-version>3.2.6.RELEASE</org.springframework.security-version>
<org.springframework.integration-mail-version>4.0.6.RELEASE</org.springframework.integration-mail-version>
<org.springframework.integration-mail-version>4.1.2.RELEASE</org.springframework.integration-mail-version>
<com.fasterxml.jackson-version>2.5.1</com.fasterxml.jackson-version>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.url>https://scm.thm.de/arsnova</project.url>
......@@ -232,7 +233,7 @@
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.11</version>
<version>4.12</version>
<scope>test</scope>
</dependency>
<dependency>
......@@ -271,12 +272,12 @@
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>aspectjrt</artifactId>
<version>1.7.4</version>
<version>1.8.5</version>
</dependency>
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>aspectjweaver</artifactId>
<version>1.7.4</version>
<version>1.8.5</version>
</dependency>
<dependency>
<groupId>org.springframework</groupId>
......@@ -286,7 +287,7 @@
<dependency>
<groupId>org.mockito</groupId>
<artifactId>mockito-all</artifactId>
<version>1.9.5</version>
<version>1.10.19</version>
<scope>test</scope>
</dependency>
<dependency>
......@@ -295,6 +296,7 @@
<version>0.73.0</version>
</dependency>
<dependency>
<!-- Tests are currently not compatible with json-path-assert >= 1.0.0 -->
<groupId>com.jayway.jsonpath</groupId>
<artifactId>json-path-assert</artifactId>
<version>0.9.1</version>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment