Commit 1570cd53 authored by Daniel Gerhardt's avatar Daniel Gerhardt

Migrate to Jetty 9.3 for development

Jetty 9.3 increases the JRE requirement to version 8.
parent 3c415a10
......@@ -85,7 +85,7 @@ Because all dependencies are handled by Maven, a complete build is done with:
mvn install
*Note:* Java 1.7 JDK is required and must be installed prior to building
*Note:* Java 1.8 JDK is required and must be installed prior to building
ARSnova.
### Requirements
......
......@@ -325,7 +325,7 @@
<plugin>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-maven-plugin</artifactId>
<version>9.2.19.v20160908</version>
<version>9.3.12.v20160915</version>
<configuration>
<scanIntervalSeconds>1</scanIntervalSeconds>
<webApp>
......@@ -333,11 +333,11 @@
<webInfIncludeJarPattern>^$</webInfIncludeJarPattern>
</webApp>
<contextHandlers>
<contextHandler implementation="org.eclipse.jetty.webapp.WebAppContext">
<contextHandler implementation="org.eclipse.jetty.maven.plugin.JettyWebAppContext">
<contextPath>/mobile</contextPath>
<resourceBase>${mobile.path}</resourceBase>
</contextHandler>
<contextHandler implementation="org.eclipse.jetty.webapp.WebAppContext">
<contextHandler implementation="org.eclipse.jetty.maven.plugin.JettyWebAppContext">
<contextPath>/customization</contextPath>
<resourceBase>${customization.path}</resourceBase>
</contextHandler>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment