Commit ba9d3304 authored by Dennis Appel's avatar Dennis Appel

Add django_heroku

parent 64f4c340
......@@ -7,6 +7,7 @@ name = "pypi"
django = "*"
"psycopg2" = "*"
gunicorn = "*"
django-heroku = "*"
[dev-packages]
pylint = "*"
......
{
"_meta": {
"hash": {
"sha256": "401ec86b81c6bceef77501c45d6cccd0bb8044d81261ac360418a198c623413f"
"sha256": "4ed7574b930d0a5bb15b8c10ad7c3d38bc044c7ff9267667924e81919a40bded"
},
"pipfile-spec": 6,
"requires": {
......@@ -16,6 +16,13 @@
]
},
"default": {
"dj-database-url": {
"hashes": [
"sha256:4aeaeb1f573c74835b0686a2b46b85990571159ffc21aa57ecd4d1e1cb334163",
"sha256:851785365761ebe4994a921b433062309eb882fedd318e1b0fcecc607ed02da9"
],
"version": "==0.5.0"
},
"django": {
"hashes": [
"sha256:1ffab268ada3d5684c05ba7ce776eaeedef360712358d6a6b340ae9f16486916",
......@@ -24,6 +31,14 @@
"index": "pypi",
"version": "==2.1.3"
},
"django-heroku": {
"hashes": [
"sha256:2bc690aab89eedbe01311752320a9a12e7548e3b0ed102681acc5736a41a4762",
"sha256:6af4bc3ae4a9b55eaad6dbe5164918982d2762661aebc9f83d9fa49f6009514e"
],
"index": "pypi",
"version": "==0.3.1"
},
"gunicorn": {
"hashes": [
"sha256:aa8e0b40b4157b36a5df5e599f45c9c76d6af43845ba3b3b0efe2c70473c2471",
......@@ -74,6 +89,13 @@
"sha256:8e0f8568c118d3077b46be7d654cc8167fa916092e28320cde048e54bfc9f1e6"
],
"version": "==2018.7"
},
"whitenoise": {
"hashes": [
"sha256:b1ddbce083c51a064da5e99dacbfff38b291d8436b6fd75156a3bb2265c55d39",
"sha256:d3609f505db173be501e8a5549d396e6013543fe126ee073b435833fc3403306"
],
"version": "==4.1.1"
}
},
"develop": {
......
......@@ -11,6 +11,7 @@ https://docs.djangoproject.com/en/2.1/ref/settings/
"""
import os
import django_heroku
# Build paths inside the project like this: os.path.join(BASE_DIR, ...)
BASE_DIR = os.path.dirname(os.path.dirname(os.path.abspath(__file__)))
......@@ -137,3 +138,4 @@ STATICFILES_DIRS = [
os.path.join(BASE_DIR, "static"),
]
django_heroku.settings(locals())
astroid==2.0.4
dj-database-url==0.5.0
Django==2.1.3
django-heroku==0.3.1
gunicorn==19.9.0
isort==4.3.4
lazy-object-proxy==1.3.1
......@@ -10,5 +12,6 @@ pylint-django==2.0.2
pylint-plugin-utils==0.4
pytz==2018.7
six==1.11.0
whitenoise==4.1.1
wrapt==1.10.11
yapf==0.24.0
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment