Replaced dynamic version numbers

parent e1f339be
......@@ -4,10 +4,10 @@ subprojects {
apply plugin: 'maven-publish'
sourceCompatibility = 1.7
version = '0.51.0-SNAPSHOT'
version = '0.51.1-SNAPSHOT'
springVersion = '4.0.+'
springSecurityVersion = '3.2.+'
springVersion = '4.0.4.RELEASE'
springSecurityVersion = '3.2.3.RELEASE'
repositories {
mavenCentral()
......@@ -18,9 +18,9 @@ subprojects {
compile group: 'commons-collections', name: 'commons-collections', version: '3.2'
compile group: 'org.springframework', name: 'spring-context', version: springVersion
compile group: 'org.springframework.security', name: 'spring-security-config', version: springSecurityVersion
compile group: 'org.codehaus.jackson', name: 'jackson-mapper-lgpl', version: '1.9+'
compile group: 'org.codehaus.jackson', name: 'jackson-mapper-lgpl', version: '1.9.13'
testCompile group: 'junit', name: 'junit', version: '4.+'
testCompile group: 'junit', name: 'junit', version: '4.11'
testCompile group: 'org.springframework', name: 'spring-test', version: springVersion
}
......
......@@ -4,16 +4,19 @@ jar {
}
}
repositories { mavenCentral() }
repositories {
mavenCentral()
mavenLocal()
}
dependencies {
compile project (':connector-model')
compile group: 'commons-collections', name: 'commons-collections', version: '3.2'
compile group: 'commons-codec', name: 'commons-codec', version: '1.7'
compile group: 'org.springframework', name: 'spring-context', version: springVersion
compile group: 'org.springframework', name: 'spring-web', version: springVersion
compile group: 'de.thm.arsnova.connector', name: 'connector-model', version: '0.+'
testCompile group: 'junit', name: 'junit', version: '4.+'
testCompile group: 'junit', name: 'junit', version: '4.11'
}
test { systemProperties 'property': 'value' }
......
......@@ -9,7 +9,10 @@ jar {
dependencies { jaxb 'com.sun.xml.bind:jaxb-xjc:2.2.4-1' }
buildscript {
repositories { mavenCentral() }
repositories {
mavenCentral()
mavenLocal()
}
dependencies { classpath 'no.entitas.gradle.jaxb:gradle-jaxb-plugin:2.0' }
}
......
......@@ -7,9 +7,13 @@ jar {
}
}
repositories { mavenCentral() }
repositories {
mavenCentral()
mavenLocal()
}
dependencies {
compile project (':connector-model')
compile group: 'commons-collections', name: 'commons-collections', version: '3.2'
compile group: 'org.springframework', name: 'spring-context', version: springVersion
compile group: 'org.springframework', name: 'spring-webmvc', version: springVersion
......@@ -18,16 +22,14 @@ dependencies {
compile group: 'org.springframework.security', name: 'spring-security-web', version: springSecurityVersion
compile group: 'org.springframework.security', name: 'spring-security-config', version: springSecurityVersion
compile group: 'org.springframework.security', name: 'spring-security-ldap', version: springSecurityVersion
compile group: 'mysql', name: 'mysql-connector-java', version: '5.1.+'
compile group: 'javax.servlet', name: 'javax.servlet-api', version: '3.0+'
compile group: 'org.hsqldb', name: 'hsqldb', version: '2.2+'
compile group: 'cglib', name: 'cglib', version: '3.0+'
compile group: 'de.thm.arsnova.connector', name: 'connector-model', version: '0.+'
compile group: 'mysql', name: 'mysql-connector-java', version: '5.1.30'
compile group: 'javax.servlet', name: 'javax.servlet-api', version: '3.0.1'
compile group: 'org.hsqldb', name: 'hsqldb', version: '2.3.2'
compile group: 'cglib', name: 'cglib', version: '3.1'
testCompile group: 'junit', name: 'junit', version: '4.+'
testCompile group: 'org.mockito', name: 'mockito-core', version: '1.9.+'
testCompile group: 'org.dbunit', name: 'dbunit', version: '2.4.+'
testCompile group: 'org.slf4j', name: 'slf4j-log4j12', version: '1.5.6'
testCompile group: 'junit', name: 'junit', version: '4.11'
testCompile group: 'org.mockito', name: 'mockito-core', version: '1.9.5'
testCompile group: 'org.dbunit', name: 'dbunit', version: '2.5.0'
}
test { systemProperties 'property': 'value' }
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment